PDA

View Full Version : Linux (Ubuntu, etc)



Random
December 9th, 2014, 09:01 AM
Anyone gotten the new release of Ubuntu to see a Windows DNLA server?

thesameguy
December 9th, 2014, 09:03 AM
Can't say that I have.

George
December 9th, 2014, 09:22 AM
No, but my wife's WinXP laptop is so old and slow and loaded with crap-ware that I am going to reformat the drive and install Ubuntu, as I did a couple years ago on an old desktop PC. I hope it works as well for the laptop as it did on the PC.

Random
December 9th, 2014, 09:25 AM
Can't say that I have.

I'm thinking it's a Windows problem a the moment, since I can see the directory on the network from the Ubuntu computer but not mount it (heyoh) despite Windows stating that it's shared. :| I can open my /pics directory, but not /music or /movies. Go figure.

thesameguy
December 9th, 2014, 09:29 AM
Any specific reason you're doing DLNA and not samba?

Random
December 9th, 2014, 01:49 PM
Any specific reason you're doing DLNA and not samba?

Because that's what worked before I upgraded to the new release of Ubuntu. :p

Random
December 9th, 2014, 01:55 PM
Hmm, maybe I just need to import the folder rather than looking for it using DLNA.

thesameguy
December 9th, 2014, 01:58 PM
ROFL.

I would give samba a go, personally, it works very well these days (has for a long time) and you don't run into the weird DLNA compatibility issues. It should also reduce the load on the server and the network, since you relocate the heavy decoding to the client. Since your client is smart (running Linux, as opposed to a TV) there really isn't a reason to not do the decoding there. That is the most efficient. There isn't much Linux won't decode these days. That would be my approach. It should just work, pretty much like magic. I have never tried PC to PC DLNA. In fact, I hate DLNA, and wouldn't try it unless it was a last resort. :p

overpowered
December 9th, 2014, 08:29 PM
What tsg said.

George
July 21st, 2015, 07:36 PM
I've been running Ubuntu for a while now on an old laptop - maybe a year or so. I didn't realize how much I liked it until recently when I stopped to think about it when a co-worker and good friend who is from Europe and heavily into European soccer/football talked about going to sketchy Romanian websites to stream games online, and worrying about viruses and such. I brought my laptop to work one day so he could click around on it and experience the Ubuntu 14.04 OS, however briefly, to realize that even a caveman can do it.

At home we have computers running Windows 8, Mac OS System 8 - and yes, I know that's the computer equivalent of listening to albums on reel-to-reel tapes, but it still works! - whatever OS iPads run, and Ubuntu. Ubuntu is the easiest of all, the adblock add-on in Firefox works beautifully, and as I told my friend who apparently has one "honest" computer at home running Windows XP and one sort of "exploratory" computer for European soccer, and probably pr0n and who knows what else from eastern Europe: there is NOTHING I've wanted to do with a computer (and an old computer, too) that I haven't been able to do with Ubuntu. My kids have played games on the Ubuntu laptop and it doesn't give them pause for even a second. They just know how to work it.

My scanner, printer, cheap-ass flip phone, digital camera, old-school digital video camera, USB flash drives, wife's iPhone, and everything else I've plugged into it via USB is immediately recognized and useable.

Okay, maybe it won't kick ass while crunching huge Excel spreadsheets with multi-hundred megabyte spreadsheets chock full o' formulae, but I can't see using anything else for my home needs.

Signed,

A Satisfied Customer

thesameguy
July 21st, 2015, 08:13 PM
Ubuntu is rad unless you happen to a specific thing you want to do that it doesn't support, like Windows games or Adobe products. Then you're hosed. For most of American homes, though, it's beyond plenty.

George
July 22nd, 2015, 09:20 AM
I forgot, Ubuntu also recognizes my probably ten-year-old Sansa Fuze 4GB mp3 player. That's good, as I still use it sometimes.

I'd like to get a newer box or laptop with a HDMI output running Ubuntu so I could run a cable to our HDTV for streaming. My old laptop is kind of quirky. Sometimes Firefox will suddenly crash while I'm watching a video, and I get these pop-ups saying "System Problem Detected. Send Report?" I always hit Cancel on that one, and once in a while when I boot up I get something like a blue screen of death and an angry beep saying there's no hard drive detected, so I imagine this laptop is on its last legs. I would be fun to see how this OS works on a newer, more powerful machine.

Finally, I got into the series Star Trek Enterprise (the one with Scott Bakula) a while back and was enjoying streaming it for free with the large external monitor from Hulu.com - just the plain Hulu, not Hulu Plus. One night I turned off an episode on the Ubuntu machine and went to bed with an iPad and headphones, thinking I'd finish the last few minutes on that device before going to sleep. Nope. It said I had to open an account with Hulu in order to view anything from the iPad, using the Safari browser. The Ubuntu machine gives no such message. I can browse and play whatever I want there on Ubuntu without having to create an account or anthing else of that nature.

Have you guys seen the System76 Meerkat? Looks pretty cool to me.

https://system76.com/desktops/meerkat#

https://system76.com/images/desktops/meerkat/meer1/small-but-fierce_1280.jpg

SportWagon
December 8th, 2015, 03:30 PM
Yes, I'm running Ubuntu 14.04 on an older laptop connected to a large monitor and it's a fine basement computer for emailing, websurfing, and streaming video, like the occasional weekend movie I'll watch while doing boring stuff like ironing, getting my cycling gear ready for the work week, etc.

[...]

Speaking of Ubuntu, I keep meaning to make an account at ubuntuforums.org to ask why I no longer get updates, and why the Ubuntu Software Center closes itself (or crashes) when I try to launch it. I'm also unable to update Firefox, even though I keep getting messages that it's out of date and I have to click "Allow" to watch Flash videos. Maybe I should ask in our Ubuntu thread at this forum, since I just hate making yet another account at a website with yet another user name and password to remember. Other than no updating, the old Dell runs great, and I can't see the need to use any other OS, at least for my current needs.


Did your install create a ridiculously small /boot partition which quickly
overflowed with kernel updates?

In a command-line (shell) window, what does "df -h /boot" say?

George
December 14th, 2015, 11:48 AM
Update for SW - sorry, but I've done nothing more about this yet. I need to spend some time learning about Ubuntu and/or Linux, because I don't even know what a command-line (shell) window is, or what df-h/boot is either.

All I know about the installation was that I chose to make it a 100% Ubuntu machine. I don't have the option of booting in WinXP any more.

I do still have the installation CD and have thought of just reformatting it again, since I don't have anything saved on this PC, and the few programs I've downloaded are easily downloaded again - Thunderbird, Open Arena, scanning software, etc.

SportWagon
December 14th, 2015, 02:13 PM
Update for SW - sorry, but I've done nothing more about this yet. I need to spend some time learning about Ubuntu and/or Linux, because I don't even know what a command-line (shell) window is, or what df-h/boot is either.

All I know about the installation was that I chose to make it a 100% Ubuntu machine. I don't have the option of booting in WinXP any more.

I do still have the installation CD and have thought of just reformatting it again, since I don't have anything saved on this PC, and the few programs I've downloaded are easily downloaded again - Thunderbird, Open Arena, scanning software, etc.

Well, for a start I said "df -h /boot" not "df-h/boot".


sportwagon@ubuntu:~$ df -h /boot
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 134M 97M 28M 79% /boot
sportwagon@ubuntu:~$ df-h/boot
-bash: df-h/boot: No such file or directory
sportwagon@ubuntu:~$

If what I think happened happened, you'd need a fairly extensive command-line session to get things to the state where the graphical Update Manager would work again.

SportWagon
February 26th, 2016, 08:34 AM
Anybody else tried 16.04 yet?

thesameguy
February 29th, 2016, 08:42 AM
Yes, but in very limited capacity. :)

SportWagon
February 29th, 2016, 01:39 PM
So I initially ran it in a VirtualBox (https://en.wikipedia.org/wiki/VirtualBox). Just download the "CD" and put it in the virtual drive. Tested, and eventually installed on the VirtualBox.

Then I got distracted though booting a loop-back root of an old 10.04 image on the same VirtualBox.

But eventually I wanted an actual 16.04 bootable USB, and it seemed problematic. Intermediate versions of the standard Ubuntu startup creator wouldn't install a different version CD image, and a third-party one I had seemed to produce a stick which failed to boot.

Initially I had tried elevating the privileges of the VirtualBox so its running 16.04 partition could write to a USB device (stick). I had thought that had not worked, but likely it had. Among other things I'd forgotten which F key to press and even where to look for the boot process telling me that. After I verified the USB stick process with an older bootable USB, I tried creating the stick in the 16.04 VirtualBox again.

And it worked!

Got some boring stuff to do before the end of today so adding a multiboot to 16.04 directly will wait a day or two.

I notice in a little playing, with a couple of alternative window managers (alternatives to Unity), that the "xsetroot" command seems to be silently ignored.

thesameguy
February 29th, 2016, 02:16 PM
Sounds like an interesting virtualbox interaction. I have only run it on metal doing a few specific tasks (namely lamp) without any issues. I only refresh these systems once in a while, so coming from 13.xx (IIRC) it was a nice improvement. Every time everything gets easier. Pretty soon I'm going to have to stop upgrading stuff or I'll no longer be needed. :p

George
March 14th, 2016, 05:53 AM
Well, for a start I said "df -h /boot" not "df-h/boot".


sportwagon@ubuntu:~$ df -h /boot
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 134M 97M 28M 79% /boot


If what I think happened happened, you'd need a fairly extensive command-line session to get things to the state where the graphical Update Manager would work again.

Finally, here is my answer:



ubuntu1@ubuntu1-Latitude-D620:~$ df -h /boot
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 73G 15G 54G 22% /


I notice SW's result include the word "boot" that I have bolded in the quote above. I don't know what that means, but I wanted to clarify that mine does not say that. The lack of that word in my results is not due to incomplete copying and pasting on my part.

SportWagon
March 14th, 2016, 03:04 PM
Well. that's probably because what I thought had happened had not happened.

Ubuntu likes to designate a too-small dedicated /boot partition which it then fills with kernels. (Or at one point it started doing this, in any case).

So it can quite quickly get a system to the state where there is no room for new kernels, even though there's plenty of room for updates, causing needless effective wastage of space (and an inability to apply new updates) as the kernel updates artificially exhaust the space on the small dedicated /boot partition.

But it looks like that actually was not the problem in this case.

54G should be enough room for lots of kernel updates.



sportwagon@ubuntu:~$ df -h /boot /
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 134M 68M 57M 55% /boot
/dev/mapper/CAC_VG-CAC_LV 38G 11G 26G 30% /
sportwagon@ubuntu:~$


And now, after a kernel update has been applied...


sportwagon@ubuntu:~$ df -h /boot /
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 134M 97M 28M 79% /boot
/dev/mapper/CAC_VG-CAC_LV 38G 11G 25G 31% /
sportwagon@ubuntu:~$


Note that /boot says "79%" (with 3 alternate kernels).
One more (new/alternate kernel) would fill that partition up, breaking the update partway through. This has happened to me on this system.

Sigh...


sportwagon@ubuntu:~$ sudo apt-get autoremove
[sudo] password for sportwagon:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
linux-headers-3.13.0-77 linux-headers-3.13.0-77-generic
linux-image-3.13.0-77-generic linux-image-extra-3.13.0-77-generic
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
After this operation, 271 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 116716 files and directories currently installed.)
Removing linux-headers-3.13.0-77-generic (3.13.0-77.121) ...
Removing linux-headers-3.13.0-77 (3.13.0-77.121) ...
Removing linux-image-extra-3.13.0-77-generic (3.13.0-77.121) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-77-generic /boot/vmlinuz-3.13.0-77-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-77-generic /boot/vmlinuz-3.13.0-77-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-77-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.13.0-77-generic /boot/vmlinuz-3.13.0-77-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-77-generic /boot/vmlinuz-3.13.0-77-generic
Generating grub configuration file ...
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-83-generic
Found initrd image: /boot/initrd.img-3.13.0-83-generic
Found linux image: /boot/vmlinuz-3.13.0-79-generic
Found initrd image: /boot/initrd.img-3.13.0-79-generic
Found linux image: /boot/vmlinuz-3.13.0-77-generic
Found initrd image: /boot/initrd.img-3.13.0-77-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
done
Removing linux-image-3.13.0-77-generic (3.13.0-77.121) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-77-generic /boot/vmlinuz-3.13.0-77-generic
update-initramfs: Deleting /boot/initrd.img-3.13.0-77-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-77-generic /boot/vmlinuz-3.13.0-77-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-83-generic
Found initrd image: /boot/initrd.img-3.13.0-83-generic
Found linux image: /boot/vmlinuz-3.13.0-79-generic
Found initrd image: /boot/initrd.img-3.13.0-79-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
done
sportwagon@ubuntu:~$ df -h /boot /
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 134M 68M 57M 55% /boot
/dev/mapper/CAC_VG-CAC_LV 38G 11G 26G 30% /
sportwagon@ubuntu:~$
sportwagon@ubuntu:~$ sync
sportwagon@ubuntu:~$ sync
sportwagon@ubuntu:~$ sync
sportwagon@ubuntu:~$ sudo reboot


In summary, you are not exhibiting the problem I referred to.
Though my cloud server (above) still is.

It's not impossible that they changed the default filesystem layout between the two times you did your installation.

The reason for creating the condition is to arrange that your kernels can be on a bootable filesystem while most of your software and other files (root filesystem) is on a spiffy new filesystem from which you cannot boot. For most users the spiffiiness of the new filesystem does not justify the inconvenience in applying updates. (Though, in reality, you only very rarely need more than one backup version of kernel, so the encouraged "good housekeeping" is overall not a bad thing).

George
March 16th, 2016, 04:51 AM
Thanks SportWagon! I appreciate you taking the time to help.

I finally sat down to try to resolve my problems and found the answers just about immediately via google results. I had two problems.

1. The Ubuntu Software Center wouldn't launch completely. It would just about get there, and then disappear. I solved that my copying and pasting this into the Terminal - which I now know now to launch. Yay!

sudo apt-get remove software-center

And then...

sudo apt-get update

sudo apt-get install software-center

2. I used to get a pop up window just about daily asking if I'd like to download updates. A few months ago, those stopped. The only thing I noticed is when I'd load a page that had videos on it, such as the "What Are You Listening To" thread in the Pit Stop, I would have to "Allow" each one in order to view it. That wasn't a problem, really, since it let pages load quickly and then I could decide what to allow, but it told me something wasn't right.

Simply running

sudo apt-get update

solved that problem. The computer is now getting those frequent updates, and as far as I know, all is as it should be on this old laptop.

Thanks again for the advice and attempts to assist. Much appreciated.

George
March 16th, 2016, 05:05 AM
Speaking of old laptops, my parents gave me their Hewlett Packard Compaq 8510p laptop to perhaps fix or recycle for them if it's time to play Taps. About all I know about it is there's a sticker on it saying "Intel Centrino vpro inside" and it was running Windows 7, and apparently without problems until it stopped turning on. They said there used to be a light on the front edge, sort of where you rest your palms while typing, when it was plugged in (which was always - they didn't carry the laptop around to different places). Now there are no lights. Thinking it might be the power supply, I plugged in a Dell power supply, which to my surprise, has the same sized...um...thing...that plugs into the laptop for AC power. No luck, and I know for sure the Dell power supply works, both from seeing a green light on the big blocky part in the middle, and also because it powers my Ubuntu Dell laptop.

There's a used PC shop nearby that I trust. I'm thinking about dropping in with the laptop to see if they have any ideas, but I thought I'd mention it here too, in case any of you computer gurus wants to take a guess. Thanks.

thesameguy
March 16th, 2016, 09:57 AM
Do you have a multimeter? It's easy to check the output voltage from the factory PSU.

Be *really* careful about plugging Dell power supplies into other laptops. Virtually ever Dell has a tiny, delicate center pin which carries PSU info for the computer to read. Plugging a Dell PSU into another laptop can mash that pin, rendering the entire PSU useless.

Suspects on the HP:

1. Bad PSU - check with a multimeter
2. Bad motherboard - no good way to check
3. Bad CMOS battery - there is a small coin-cell battery on the motherboard that retains CMOS information. There are several generations of laptops that will not power up if their CMOS battery is dead. Dumb design. The battery is easy and cheap to replace if you can get to it.

George
March 16th, 2016, 01:43 PM
Bad CMOS battery...

:eek:

http://h20464.www2.hp.com/media/9C35219B-2E35-42F4-8DA3-557C24BDEE39/vb_FRU_video_real-timeclockbattery.htm

Wow. Gonna try this ASAP. I would never have guessed there was a little battery in there. Thanks!

Also parking this link here for my own future use - how to take this particular laptop apart in greater detail than above. The two videos together ought to do the trick. :up:

https://www.youtube.com/watch?v=FKCnQ-mIiVI

George
March 16th, 2016, 02:26 PM
I have the battery out and am heading to Batteries Plus in the hopes they have one of these: http://www.amazon.com/HP-501587-001-Battery-Coin-Cell/dp/B004JASJYQ (just another link for my future reference in case I need to order it). MicroCenter says they don't carry them but the guy at BP is a good salesman and said, "There's a good chance we have it, or can order it. Can you bring it in for us to look at?" Ah, what the hell. I hate ordering stuff online, so I'm going over to see if they have one.

thesameguy
March 16th, 2016, 03:01 PM
Did you say you hate driving places so you order everything online? I didn't quite hear you.

George
March 16th, 2016, 05:27 PM
Time for a new RTC battery for your hearing aid, gramps! I like to try before I buy.

More link-leaving for later:

For replacement parts (i.e. batteries, AC adapters & power cords, etc..), call 1-800-227-8164 between 7:00 AM - 7:00 PM, Monday - Friday. For more information go to, www.hp.com/go/hpparts.

Is this rude forum behavior? Probably. But I've been hanging out in Los Santos for so long that I'm getting used to the selfish side of life.

thesameguy
March 16th, 2016, 06:13 PM
Hint: Ebay

SportWagon
March 23rd, 2016, 09:40 AM
Eventually 14.04 found the fglrx drivers for something similar to http://www.amazon.co.uk/HP-Pavilion-15-P251NA-Laptop-BeatsAudio/dp/B00QX4XAKE

Else life was going to be miserable stuck in 800x600.

HDMI output also now seems to be working reasonably.

George
April 4th, 2016, 05:15 AM
I'm going to try this.

It's a shame this guy doesn't speak English. :lol:




https://www.youtube.com/watch?v=5DdAZrTZjEM

thesameguy
April 4th, 2016, 09:39 AM
Meh, just look at the pictures!

Also, be sure you have the correct battery - most are 3v, so you're fine there, but a 2032 is thicker than a 2016 and may not fit where you need it. ;)

Of course, you'll be dismantling the laptop to get to the existing battery, so you can pseudo-check it with a voltmeter before going further, and you'll be totally discombobulating the existing battery to steal its wires, so you'll get to see what it is before buying the replacement.

I am assuming you have a heat gun - because if you don't it's gotta be cheaper to just buy a ready-made battery than a heat gun. Although, heat guns are super fun to have around, so there's that. ;) Still, having a hard time believing heat gun + battery + heat shrink + solder is cheaper than an ebay battery in the first place, but I've never actually priced it out. Whatevs, still a fun project. :)

George
April 4th, 2016, 06:42 PM
Yeah, I have a heat gun. For all my apparent online cluelessness about all things, I have been collecting and using tools for a long time. I have a couple voltmeters, too, and one that has been somehow working since the 1980s without a new battery. I figure the devil will make me answer for that someday.

I checked ebay and found one (1) battery for this old laptop. Seller wanted $36 for a USED battery. No thanks.

I called HP and they wanted $49 for a battery, but they said it was back-ordered, which I assume means they'll build one to order, but not until I give them my credit card number.

Dude with good sales skills and the really deep voice at the local Batteries Plus store has the battery I need, and I'll get the conductive tape and heat-shrink stuff at my preferred old-school Ace Hardware store between there and there. I started to ride my bike over there this morning but other priorities got in my way.

But as this is the Ubuntu/Linux thread, let me just add that I giggle with glee each time I fire up my old Dell laptop in the basement and enjoy the Ubuntu OS. My wife uses Windows 8, which I find intolerable with all the pop-ups and various bullshit that she's always asking me to fix.

Ubuntu is so simple, and that's why I want to get a battery for the HP laptop, so my son and I can have two laptops in the basement and enjoy a 24-7 LAN Open Arena deathmatch. :D

The HP laptop was my mother's but she wants a tablet now. I've advised my parents to buy a refurbished iPad from Apple, and an external keyboard, and some kind of a cover for the glass top of the iPad. We have two of those, and they work well. Mom just wants to be able to sit in her chair and surf the web and I think an iPad is the right device for that.

Edited to add: one of these days, I'm going to beg for help from you guys to build a box to run ubuntu studio. I'd enjoy the music recording capability and my daughter needs some kind of tablet/drawing thing. She's going to put Cam out of a job.

https://ubuntustudio.org/

JoshInKC
April 5th, 2016, 06:02 AM
Might have to give this a shot if/when I get some free time between semester end and summer digging

ArcheOS - The Archaeological Linux Distribution (http://www.archeos.eu/index.html)

thesameguy
April 5th, 2016, 08:54 AM
Windows 8??? Get her on 10, stat!

Random
April 5th, 2016, 10:52 AM
Word.

SportWagon
April 5th, 2016, 02:26 PM
Yes. Microsoft needs all your personal information.

Anyway, he's proposing to throw away Windows entirely. And if he still has its license, he can try Wine, and possibly VirtualBox.

George
May 9th, 2016, 04:51 PM
Hey SportWagon, and any other Ubuntu experts - any thoughts on running the Ubuntu Studio OS on a 6th Gen i7 system? I'm hearing there may be some incompatibilities and a wise friend suggested I ask here.

I'm this close to buying a new (or refurbed but recent) Dell and don't want to end up with buyer's remorse, if there is solid evidence of problems. The ubuntustudio.org website has a hardware section, but I find it rather vague.

Thanks.

SportWagon
May 10th, 2016, 08:31 AM
Our standard wisdom where I am is now that Intel has become more easily compatible than AMD for Ubuntu/Linux graphics drivers.

14.04 or 16.04?

George
May 10th, 2016, 06:07 PM
Glad to hear that. Thanks.

I have my eye on Ubuntu Studio 16.04.

overpowered
July 2nd, 2016, 03:03 PM
Linux is running almost 2.5% of market share on W3C counter which gets its data from web hits -- desktop users. Linux is big in the server market but

https://www.w3counter.com/globalstats.php?year=2016&month=6

Also notable from that page, Firefox is beating IE/Edge.

George
July 2nd, 2016, 03:39 PM
I'm pleased to see that, if only because if reaffirms my choice to run Ubuntu on my home PC. I should say that's MY home PC, and not the choice of my wife or kids, but I like it. It's a simple OS with elements of classic Windows and Mac features that, it seems to me, anyone could start using immediately. I've had no - zero - none - of the bullshit my wife gets on her Windows machine with all the popups threatening immediate doom and whatnot.

As just a consumer and not a computer pro like some of you guys, I must say I'm surprised that Macs (not iOS) still have such a small market share. I would have thought all the iPod, iPad, and iPhone users would have naturally moved toward Macintoshes for their desktop needs, if only for familiarity and the amateur (that's me!) assumption of greater compatibility.

I would assume the smaller share of the market earned by Macs is due to the same reason as always: they cost a friggin' fortune, and I say that as someone who is actively shopping for a new desktop PC. Even used/refurbished/God-knows-what iMacs from 2013 have asking prices of over a grand! Just this week I visited my local MicroCenter (www.microcenter.com) store to see an iMac in person and click around on it and launch GarageBand and I was struck my how flimsy the whole thing seemed to be, physically. Macs didn't used to be like that, and a guy at work won't shut up (and I'm glad) about how poorly made Chinese Macs are these days, and how - apparently, I haven't researched this on my own - you can't upgrade them, such as adding RAM or changing sound cards or video cars or hard drives, etc.

Maybe that's why everyone buys Dells and Windows and suffers with all those damn popups and viruses and "It looks like you're writing a letter. Would you like help?"

For the fiftieth, if not one hundredth time, NO, Mr. Paper Clip Assistant Dude. :angry:

But I don't deal with him anymore, or any of that other crap. Let's see...how do those iWhatever people do it:

This message brought to you by Ubuntu 14.04

(disclaimer: I surf this site on an iPad as often as I use the Ubuntu machine in the basement :eek:)

Yw-slayer
July 3rd, 2016, 09:51 PM
Macs didn't used to be like that, and a guy at work won't shut up (and I'm glad) about how poorly made Chinese Macs are these days, and how - apparently, I haven't researched this on my own - you can't upgrade them, such as adding RAM or changing sound cards or video cars or hard drives, etc.

Lol. I always understood that Macs (save for Mac Pros and maybe some of the really REALLY early imacs?) have been impossible to upgrade for years.

George
July 13th, 2016, 06:19 PM
I guess it depends on how you think about "years". I clearly remember lifting the lid of the Mac IIci boxes where I worked in the mid-90s and changing from SIMMs to DIMMs or something along those lines. I think we went from 8 to 16 MB of RAM, or maybe 16 to 32 MB. I don't know the numbers for sure, but I know it was MEGAbytes and not GIGAbytes back then.

I remember reading Mac World or Mac User or some such magazines on my lunch breaks in the company lunch room and learning about the latest Macs that could hold as much as 256 MB of RAM, which was mind-blowing back then. The company subscribed to the magazine, which broke news about things like the new World Wide Web and DVDs - the latter an acronym so awkward to say that I thought it would never come into the common vernacular in the way CDs had a few years earlier. Another hot topic during those years were the coming Mac Clones, and we had one soon after, although I can't remember the name; only that it had a red, circular logo. And of course, this was back when the Apple logo had rainbow stripes.

Edited to add: Power Computing! It's all coming back to me now.

I'm also fairly sure I remember upgrading my first Mac, a Performa 630CD that I bought in 1996, I think, in a similar fashion. 8 MB to 16 MB stands out in my memory, but I suppose I could wrong about the particulars.

It's funny that 20 years after buying my first Mac, and over 25 years since I first used a Mac, I'm STILL fighting the Mac vs. PC battle in my mind, and now the Ubuntu OS is in the mix too, just to make things even more confusing.

As with most things in life, a giant sack of cash would make my choices much simpler.

Yw-slayer
July 13th, 2016, 11:14 PM
By "years", I meant "years", not "decades". So I mean at least since the all-in-one aluminium iMacs were introduced, and even the pod with the movable monitor (second-gen model).

PCs 4 Ly43

thesameguy
July 14th, 2016, 12:34 AM
You can upgrade that AIOs. I've done it quite recently. You're not replacing motherboards or anything, but CPU/RAM/drive are all doable.

George
July 14th, 2016, 06:21 AM
If there was an open-source app similar to GarageBand, I wouldn't be wasting time thinking about this. I'd have a new Dell running Ubuntu here already.

Lately I'm looking at a dollar comparison of these two options:

1. Brand new 27" Apple iMac

Or, for approximately the same cost, EVERYTHING listed below

1. Dell XPS 8900 or similar from the Dell Outlet
2. Maybe a 24" or 27" monitor, although I have a decent monitor already, and of course keyboards and mice for PC already
3. A couple better microphones for home recording
4. A new 88-key MIDI keyboard, medium quality (not entry level, but not a pro stage unit either)
5. USB audio interface
6. Medium quality home studio monitors (Mackie makes some really affordable ones that get great reviews)

AND, probably still within the cost of a new iMac...

7. Decent used drum kit from craigslist or a local drum shop I know and like, on the small side - say a four-piece kit with hi-hat, crash, and ride cymbals - and my kids and I learn to play the drums together.

As much as I think I'd enjoy GarageBand from videos I've watched, the latter seems like it might be more fun and better since it would involve the kids instead of just me hiding out in the basement with a guitar plugged into a computer.

In other Linux/Ubuntu news, I recently visited www.system76.com, the Denver-based company that sells Ubuntu machines, and found this silly video about Tux the penguin's 4th of July adventures. Weird. But that's how things are in Colorado, sometimes.


https://www.youtube.com/watch?time_continue=185&v=EvDuDbmRWzA

overpowered
July 25th, 2016, 11:11 PM
Just tried Fedora Workstation (regular Gnome3) in a VirtualBox.

Holy crap. Gnome3 sucks. Apparently it's designed for people who don't do programming. I wanted to make sure I had zlib-devel and gcc-c++ for something I wanted to build and the software installation GUI can't seem to find those installed or find them to install from a repository. I also wanted kernel-devel which is needed to install the VirtualBox guest additions. Same problem. Apparently if you're not looking for a browser or a paint tool, the install GUI doesn't know what the fuck you want.

I managed to find them with dnf on the command line. Doing updates with dnf command line too.

The GUI is so useless that I'm back to command line for everything. Welcome to 2000. Lucky I remember how to use yum and dnf is more or less the same as yum.

mk
July 26th, 2016, 01:59 AM
Me dummy tried new lubuntu in '99 industrial machine.

George
October 21st, 2017, 08:43 AM
I'm back on the Ubuntu bandwagon after mentioning something at work about a few retired desktop machines that are just sitting in the storage room and getting more and more obsolete by the day. "Take one home!" was the reply.

So I did. My son and I created a bootable USB stick with Ubuntu 16.04 LTS on our Win10 machine, connected an older monitor, keyboard, and mouse from our spare parts pile, and in a surprisingly short time (10 minutes, maybe) were up and running. I'm posting from it now.

It's an HP Compaq dc5800 Microtower, which seems poorly named because it's a very large box - easily as large as my Dell XPS 8900. I'm wondering it might work as a generic box for a build-your-own PC in the future. It has the old serial ports for keyboard and mouse, but also six USB ports and a DVD drive that I haven't tried yet. It also has three fans, which seems like a lot. No HDMI output. It was originally a Windows Vista machine.

From the "About This Computer" screen in Ubuntu:

Memory: 1.9 GiB
Processor: Intel Core 2 Duo CPU E6550 @ 2.33 GHz x 2
Graphics: Intel Q33
OS type: 64-bit
Disk: 76.5 GB

Clicking around in the OS is fast - faster than I remember the old laptop I first installed Ubuntu on being, but I think the hard drive was dying on that one. Web surfing is fine. YouTube videos work fine.

To test the graphics beyond YT videos, I downloaded Sauerbraten, an open-source first-person shooter that I've played before. That game reveals this computer's age and/or lack of power. It's sort of choppy - playable for those of us who remember gaming in the '90s, but my son disapproves. I'm sure simple arcade-style games would do fine.

All in all, it's a perfectly good "extra" computer to have around the house.

Money spent to get this computer up and running: $0.00. :D

Tom Servo
October 23rd, 2017, 05:49 AM
:up:

mk
October 31st, 2017, 12:59 PM
Graphics: Intel Q33


https://www.videocardbenchmark.net/gpu.php?gpu=Intel+Q33+Express

Tom Servo
October 31st, 2017, 05:00 PM
Wow, that's almost magical.

George
November 1st, 2017, 02:08 PM
It's still worth what I paid for it. :D

mk
November 4th, 2017, 03:49 AM
I've recently sold two.
(real money)

Yw-slayer
November 4th, 2017, 07:05 AM
Turn it into an emulation station.

George
November 6th, 2017, 09:50 AM
I've recently sold two.
(real money)

Are you saying people are paying money for ten-year-old PCs, or am I missing the point?


Turn it into an emulation station.

Googled that. Looks complicated, but I'll read more.

I wonder if I couldn't use DosBox to do something similar. I tried with the last Ubuntu computer I had, but I know so little about the file system in Ubuntu that I couldn't find the MAME files or whatever they were called to launch the various arcade games after downloading them. Damn. No Duke Nukem 3D for me.

I had that same problem with other downloads that weren't from the Ubuntu app store or whatever it's called. Those "official" apps self-install just fine, including a handy icon in the taskbar, but things from other websites that say they're Ubuntu-compatible appear to download to somewhere but then I don't know what to do next.

Example: I remember on my last Ubuntu machine seeing a message saying Firefox was outdated and I should click here to download or update the new version. I did and saw something download to somewhere, but Firefox kept saying it was out of date. I'm sure there was the Linux equivalent of an .exe file somewhere, but I didn't know how to proceed.

I also have a problem waking this newest old computer after Ubuntu puts it to sleep after so many minutes of non-use. The screen goes black and the PC quiets down but still has a green light indicating it's on. Neither my son or I can figure out how to wake it up again without "crashing" it by holding in the power switch until it restarts. Surely that isn't how it's supposed to be.

But I'm not asking for help here - just commenting a little about the OS. I like it very much, but need to learn more about it.

SportWagon
November 6th, 2017, 11:18 AM
As to the detail of Firefox updates, 16.04 Firefox should stay up-to-date enough via regular apt/dpkg maintenance (done by a GUI which wakes up occasionally, or via)

george@ubuntu$ sudo apt-get update
george@ubuntu$ sudo apt-get dist-upgrade
(Enter password when prompted, and reply "yes" to apply the indicated updates).

There was a time when Firefox tended slip out of apt update mode, especially after a system upgrade, but its file locations have been regularized now and so Ubuntu packaging (apt, dpkg) tends to keep it up-to-date.


Under Linux a .exe will tend to simply have no extension; the output from "ls -ld" will have "x" to indicate the file is executable (usually three, e.g.


-rwxr-xr-x 1 root root 157888 Oct 3 08:25 /usr/lib/firefox/firefox
-rwxr-xr-x 1 root root 2667 Oct 3 06:11 /usr/lib/firefox/firefox.sh

That's to be confused, of course, with a directory, where "x" means "searchable".


drwxr-xr-x 3 root root 4096 Oct 5 06:24 /etc/firefox

When I experiment, both "/usr/lib/firefox/firefox.sh" and "/usr/lib/firefox/firefox" behave similarly, though in my case bringing up a chooser. So I create a new profile and get to see Crash Bandicoot (well, it sure looks like Crash Bandicoot) looking at a sunrise. (Or is it sunset?)

And sigh, come interpreters, e.g. php, will interpret files without the "x" perfectly well.



I also have a problem waking this newest old computer after Ubuntu puts it to sleep after so many minutes of non-use. The screen goes black and the PC quiets down but still has a green light indicating it's on. Neither my son or I can figure out how to wake it up again without "crashing" it by holding in the power switch until it restarts. Surely that isn't how it's supposed to be.

When it does that again, try hitting "CTRL-ALT-F1" (altogether; well sequentially will do, so you end up with all three keys pressed at once; er, that is, analogous to "CTRL-ALT-DEL", duh). And then, after releasing, maybe hit "Return" a couple of times. You might get a login prompt for a dumb terminal command-line login session. If you enter your username (which you might not actually know because of the nature of the GUI login) and password you will then be in bare-bones Linux. At that point you would at least to be able to shutdown or restart it cleanly. Getting the screen to wake up that way probably wouldn't be trivial. Although there's a remote chance "CTRL-ALT-F7" would bring the GUI back to life after that. (tty7 being where the GUI normally runs) (I am assuming here that you've already tried typing on the keyboard and jiggling the mouse; I had one machine go unresponsive like that recently, it's sort of annoying).

Perhaps play with the "CTRL-ALT-F1" (or F2,F3,F4,F5,F6) screens just for fun/educational purposes some time, anyway.



george@ubuntu$ sync
george@ubuntu$ sudo reboot

Or

george@ubuntu$ sync
george@ubuntu$ sudo shutdown now


As to third-party packages, it's been a long time since I downloaded any.

mk
November 7th, 2017, 12:42 AM
Are you saying people are paying money for ten-year-old PCs, or am I missing the point?

Yes, the first one.

The point you are missing is that DOS is not dead, needs to be connected and is not supported.
AFAIK W2k to Vista and Linux Samba can be used for linking and recently Samba has been less than stabile.
So if you dont want Linux and want to keep your stuff legal you need to find an old Windows license.
(embedded ARM something may also be possible)

For sleep mode,
you can check your Linux GUI by booting the machine with monitor disconnected.
If afterwards connected monitor stays dark you can be sure you will have problems.
GUI can be started with startx but having many of them is possibly not so good.

SportWagon
November 7th, 2017, 08:11 AM
I sort of suspect his system goes to a mode where all ttys (displays and keyboard) have gone to sleep somehow. I would guess he or his son would have tried CTRL-ALT-DEL and it probably didn't visibly respond, so CTRL-ALT-F1 probably won't make a visible change either.

Of course, I don't use CTRL-ALT-DEL very often with Linux, and when I try it now on a laptop it seems unreliable and never goes into any useful intercept, but occasionally does an emergency reboot, only slightly safer than power cycle. So, in short, I think my CTRL-ALT-F1 suggestion stands.

My most recent laptop (a different one) did go into the dark and no response mode once, and I don't think CTRL-ALT-F1 worked and I did the power cycle thing. That laptop keeps getting better with every update, especially kernel updates however. The same can't be expected to happen for ancient hardware, however. (Of course, in both my case and theirs. there is the possibility the whole system has just crashed).

They probably don't run an ssh server on the box and likely wouldn't have any clients to ssh into it when it's in dark mode either. Leaving aside the fact that command-line mode is mostly a mystery to them, I think.

http://matt.might.net/articles/basic-unix/
tries to be a quick tutorial of sorts.

mk
November 8th, 2017, 02:21 AM
cnet specs for DC5800 has PS/2 keyboard.

PS/ or USB keyboard now?

BIOS update available?

Tom Servo
November 8th, 2017, 07:17 AM
I had some similar issues when I had power settings set to put the computer to sleep/hibernate when not being used, then being basically unable to wake up from that state. Admittedly, I've also had the same issue with Windows, those sleep states have always been really dodgy in my experience.

George
November 8th, 2017, 08:25 AM
command-line mode is mostly a mystery to them, I think.

If you're speaking of my son and me, you are correct. Plug & play for us, please! :D (at least at this stage of our Linux education)

I am grateful for all the tips and tricks and links here. Thanks to SW and mk and TS. :up:


So if you dont want Linux and want to keep your stuff legal you need to find an old Windows license.
(embedded ARM something may also be possible)

If you or anyone wants them, I have a Windows 95 CD and a Windows XP CD that are original and undamaged (as far as I know).

thesameguy
November 8th, 2017, 09:02 AM
Two thoughts:

Some old computers inexplicably have "wake by USB" disabled in the BIOS, so when the system sleeps it won't wake up via USB peripherals. I'd check that.

Also, generally speaking you should be able to wake the computer by pressing the power button once. Don't hold it.

In both cases, be patient. Old computers can take some time to wake up.

George
November 8th, 2017, 09:13 AM
...just like old people! Thanks for the advice.

And it occurs to me that the Ubuntu machine has serial ports for the keyboard and mouse, but we have USB peripherals attached currently. I know we have a few serial cable mice in the back room at work (where I got the old PC from). I'll have to take one home and try it.

More foolishness, if anyone cares:

My son loves to explore and try things and, like most kids, an adult telling him something won't work only encourages him to try harder.

Over the weekend, we (but almost entirely he) installed Ubuntu Studio on our new/old computer and set it up as a dual boot setup between plain old Ubuntu and Ubuntu Studio. Wow, Ubuntu Studio is a nice-looking OS. I haven't tried any of the included open-source audio and video programs, and I doubt that old machine has enough RAM to do much, but I'm glad to see him teaching himself about computers.

Now, let's go back in time to 1998. I was an outside sales rep for an equipment manufacturer. The company required us to purchase Dell Latitude laptops running Windows98 with CD-ROM drives so we could demo equipment by setting the laptop up on a prospect's desk or in a conference room and have people watch videos of the machines we sold. The cost per employee was three grand! There was a payroll/commission deduction program so we didn't have to cough up the money up front, but that still seemed like an incredible extravagance to me. But, I had just taken the job and dreams of making big money (as all sales jobs promise) loomed large in my mind. I had to carry a pager for that job too, just as an historical footnote.

Naturally, the job didn't last, but the computer sure did. It was our home computer for years and years. I used to visit Kenji's original GT forums on it. When we moved to Colorado in 2004, it was still working fine. Somewhere along the way, we bought a new Dell desktop machine and used the old laptop less and less - smaller monitor, slower machine, etc. One day I tried to boot it and found the screen was dead, even though I could hear the usual whirring of the machine turning on and the lights coming on the keyboard. A quick search of laptop screen replacement or repair scared me away from spending money on what was then a very old laptop. It ended up in a pile of old cords and cables and whatnot in a box in the basement for several years...for at least the nine years we've had kids, and probably more.

Guess what my son found recently? Yup, that old laptop. The monitor still doesn't work, but we have a couple extra monitors around the house...or HAD a couple, since now they're both in use. The larger/better one is on the dual-boot Ubuntu machine, and an old, square 17" Dell monitor that I should have dumped years ago is now attached to the 1998 laptop which still boots right up after years of sitting still. I was surprised the hard drive wasn't seized up like an old, dry engine. Good thing I kept the power supply for it, too.

I don't know how long I'll keep it around, but when I get a few free minutes, I need to see if I can get that old laptop online and post a screenshot of how this forum looks on a Win98 browser. :D

thesameguy
November 8th, 2017, 09:19 AM
Enjoy your viruses!

SportWagon
November 8th, 2017, 12:24 PM
Conceptually, it would be nice if you could run both ordinary Ubuntu and Ubuntu Studio simultaneously so you could switch between them, wouldn't it?

Only tangentially related, but I might as well edit this in as double-post...

George
November 11th, 2017, 01:37 PM
I suppose that would be nice, but after spending a little time in Ubuntu Studio, I prefer it.

And, it does wake from sleep mode in Studio, I've learned. Must be an OS thing, I guess.

As before when I was running Ubuntu regularly, I'm finding myself wanting to see how it performs on a new computer instead of old ones. One of these days, I will.

2728

mk
November 12th, 2017, 02:48 AM
And, it does wake from sleep mode in Studio, I've learned. Must be an OS thing, I guess.
Can't be, must be just very tired.

For licence,
it's a serial number, database marking or something like that but not an installation media.

SportWagon
November 12th, 2017, 12:09 PM
Studio uses a different line of kernels, so it could be that Ubuntu Studio knows how to get woken up even though Ubuntu 16.04 doesn't.

George
November 13th, 2017, 10:17 AM
I spoke too soon. On Saturday I had the Studio OS running and came back into the room a few times and it woke from sleep right away after short periods of time - less than an hour each time, I'd guess.

Then I was out for a few hours and when I came home, it wouldn't wake up using the mouse and keyboard.

Oh, well. It's still fun to fool around with.

thesameguy
November 13th, 2017, 11:13 AM
Check the BIOS for devices that can wake the computer from sleep - make sure USB is one of them. Seriously.

mk
November 13th, 2017, 12:15 PM
+1

George
November 13th, 2017, 12:36 PM
Will do. I assume that's found in the F12 boot menu. If not, I'll google it.

FWIW, I found a USB to serial port adapter in a pile of computer cables and plugged a USB mouse into a serial port that way. I only tried one of the serial ports and it did not wake the computer when moved and clicked.

mk
November 14th, 2017, 02:25 AM
Boot menu is different.

When you finally get there add some boot delay so you can actually read those instructions next time.
(stupid feature)

Assuming PS/2 ports.
Those ports are usually color coded and not nesessary universal.
Hot swapping is also unknown, to be sure connect the device before power.
USB mouse and keyboard are not nesessary PS/2 compatible.

mk
March 18th, 2018, 12:09 PM
Dang, messed one of my lubuntu boxes.
The one with RAID, that is offline.
And other data area, that is part of a system disk.

Forgot that mobo-net is 10M only and tried upgrading thru it, auto mode means crap.
Obvious result was cant-do-a-thing-repair-broken-packages-fist.

With earlier added (curant)netcard and manual copies of this and that from local archive all packages are now ok but their versions are quite far from it.

Wouldn't it be nice to have distro + addenum dependencies installation possible backwards.
Dependencies generation forwards of course.

George
April 13th, 2018, 10:19 AM
Here's some Linux news I stumbled upon. It's interesting to me because I found the www.system76.com website a while back and realized they're a local (to me) company, and it's nice to see jobs return to the USA for a change.

Linux computer maker to move manufacturing to the U.S.: System76 explains why the company will soon make its computers in Denver. (https://opensource.com/article/18/4/system76-us-manufacturing-plant)