Page 86 of 89 FirstFirst ... 36768485868788 ... LastLast
Results 851 to 860 of 884

Thread: Should we have a sim racing omnibus thread?

  1. #851
    Jedi Cam's Avatar
    Join Date
    Jan 2014
    Location
    Columbia, SC
    Posts
    5,249
    I look forward to seeing it assembled.

  2. #852
    Senior Member
    Join Date
    Jan 2014
    Location
    Central Victoria
    Posts
    632
    How'd you end up with the building Blerpa? Still knee deep in bendy tubes?

  3. #853
    Senior Member
    Join Date
    Jan 2014
    Posts
    1,956
    I'm actually waiting for the seat: me and my partner agreed we cannot afford to have it hogging our corridor before taking the place of Playseat in our tiny studio.
    Still no news about the seat, hopefully it will arrive soon (before Christmas).
    I'll keep you posted about it.

  4. #854
    Jedi Cam's Avatar
    Join Date
    Jan 2014
    Location
    Columbia, SC
    Posts
    5,249
    My new rig is overdue. I ordered it over three weeks ago. Their web site claims 2-3 weeks for processing.

  5. #855
    Junior Potato
    Join Date
    Jan 2014
    Posts
    8,909
    For users of hard seats and/or pointy butts, I needed to use extra cushions to ease the pressure on my ass. They began to flatten out so I splashed out for a memory foam cushion. Early impressions are that its amazing. Hereís the link:

    Amazon Basics Memory Foam Seat Cushion - Black, Square https://amzn.asia/d/6vmRhy1

  6. #856
    Senior Member
    Join Date
    Jan 2014
    Location
    UK
    Posts
    202
    Look forward to seeing these new rigs assembled 🙂

  7. #857
    Senior Member
    Join Date
    Jan 2014
    Posts
    1,956
    I'm going to wait for the Trak Racer Rally seat to arrive and then decide if I need some lumbar support or extra cushions.
    My Kia Stonic is famous for having a tricky seat position and no lumbar support, which makes for tiresome long travels on it.
    I fixed the problem with a 20 dollar lumbar support from Amazon:



    I may buy it again for the rig

  8. #858
    Jedi Cam's Avatar
    Join Date
    Jan 2014
    Location
    Columbia, SC
    Posts
    5,249
    I got my new rig today. I spent the afternoon setting it up and did a handful of races this evening to try it. Itís pretty good but I do have a gripe with it. I plan on making a video review for it.

  9. #859
    Senior Member
    Join Date
    Jan 2014
    Posts
    1,956
    My 6 months Thrustmaster TG-T2 servo base is dead.
    Does not work anymore. Does not start. Does not even turn on the LED.
    FUCK SAKE, POS Thrustmaster crap.

  10. #860
    Jedi Cam's Avatar
    Join Date
    Jan 2014
    Location
    Columbia, SC
    Posts
    5,249

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •