Results 1 to 10 of 10

Thread: Steering wheel mount lock(?) fix

  1. #1
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,592

    Steering wheel mount lock(?) fix

    Hey guys,

    I now know that the GT Force Pro is not compatible with GT7, but it is affixed to a wheel mount I bought around 4 years ago and which I promptly lost the manual (if any) for. I somehow managed to unscrew the quick release from the... hole which it was stick into. Further attempts to remedy the situation have made it even worse.

    The first two pictures are what it looks like once I've extracted the QR. The third is the QR. The fourth is sort of what is should look like, but obviously to enable it to be re-locked. I need help to get me to re-insert the QR into the hole and ensure that it's locked properly.

    I could always just ditch it and get another frame to mount a new wheel on, but that seems wasteful even if that is unlikely to (in absolute terms) cost that much more than possibly getting someone to look at it.

    Any suggestions would be appreciated, even if it's something relatively unusual. Would it be odd to get someone (a handyman? bike shop?) to look at it?

    2022-09-25 21.39.39.jpg2022-09-25 21.39.54.jpg2022-09-25 21.40.05.jpg2022-09-25 21.40.19.jpg

  2. #2
    Junior Potato
    Join Date
    Jan 2014
    Posts
    8,909
    I don't quite understand how the thing should go together. I'm guessing the thread goes back in the hole, but you need the washer and spring to sit above the black swingy-outy arm bit?

    And what's the significance of the black material under the cam of the quick release bit? It looks damaged, or is it meant to be that way?

  3. #3
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,592
    Yes to thread going back in. Where the washer and spring go I have no real clue but it was approximately what this looked like at some point j think.

    The black material is not damaged, it is meant to look like that. I think it's to connect with something else in the picture.

    I may just take it to a local hardware dude for a look.

  4. #4
    Senior Member
    Join Date
    Jan 2014
    Location
    Central Victoria
    Posts
    632
    It'd hard to tell, but is that top washer larger than the groove?
    If it is, it looks like that may need to be put under the black flappy arm, therefore it has the spring tension pushing on the arm when you lock the locking part over.
    But you'd need to wind the thread into the bottom first, the close the flappy arm down. Think of it like bike wheel quick release.

  5. #5
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,592
    Alright, I’ll have another look tonight. Thanks mate.

  6. #6
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,592
    Bike shop agreed to look at it. Fixed it in 3 minutes. Now looking at a Thrustmaster T300 RS GT Edition.

  7. #7
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,592
    Fixed rhe T300 to it but the mount isn't solid enough to ugh as it moves around a bit.

    Will get a folding mount.

  8. #8
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,592
    Got new folding mount. That plus T300RS GT are life-changing. Doing races in GT Sport is actually enjoyable now, not just grinding for credits.

  9. #9
    Junior Potato
    Join Date
    Jan 2014
    Posts
    8,909
    Yay!

    Come join us in iRacing

  10. #10
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,592
    Thanks, but nah. I got stuff to do in real-life, like drive 3 cars.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •