Results 1 to 6 of 6

Thread: Sticky fuel gauge...

  1. #1
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,654

    Sticky fuel gauge...

    I'm pretty sure the problem isn't the gauge/dash itself because it still moves. Just very slowly. During the past couple of fill ups, it took FOREVER for the fuel indicator to reach the full position.

    Bad fuel has gummed up my tank or something?

    My car does have a tendency to stall during idle before... At first I just thought it needs new plugs. After 100k miles, I did make the change and it helped a little, but not by much. Eventually I bought a few bottles of Techron and it helped the engine run smoother noticeably. Techron also help sort of fix my mower stalling problem too!

    However, for the S2000, the idling issue seem to come back if I don't fill up with a bottle of techron in the tank..., plus, now the fuel indicator problem.

    Any other suggestions for dealing with such problems?

  2. #2
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,333
    Poor idle - fuel filter ever been replaced?


    S2000 - When was the last time the valves were adjusted? I believe it is to be done at 50k miles.

  3. #3
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,654
    I think I should have done it back during 50~60k miles. I have to double check my records...

    Anyway, I don't hear any irregular engine noises and I'm still getting similar MPG #s as before. I'm averaging 26~27 mpg right now. I can probably readjust them again just to make sure it runs smoother I suppose.

    But that sticky fuel gauge, do you think that can potentially be a big problem?

  4. #4
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,333
    S2000 is on solid lifters, poor idle qualities are usually attributed to the valves being out of adjustment.

    Stick fuel gauge, what car is this on?

  5. #5
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,654
    It's on the same car! The fuel gage isn't stuck just moving very slowly.

    This fuel indicator problem led me to believe the problem is probably more fuel related than the valves, right?

    Cheap and quick fix is to just dump in more fuel cleaners?

  6. #6
    Senior Member
    Join Date
    Jan 2014
    Posts
    5,333
    if fuel cleaner is alleviating the issue, the problem could be more in-depth. I think the valves are supposed to be adjusted at 100k.

    Fuel filter needs to be replaced q30k on most vehicles. The slow gauge might be from something with the sender, but any inferences I would draw are likely to be incorrect.



    I am saying that the poor idle is likely to be caused from valves and fuel filter. It also wouldn't hurt to get the injectors flushed professionally.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •